Is this giving a problem when you run php artisan serve?

|
Stoyt 2022-04-03 14:22:38
zey34354 2022-04-03 14:19:44
what is the problem in this exactly ?

Wtf ?? 😐

cletuskingdom 2022-04-03 14:34:27
zey34354 2022-04-03 13:08:36
I have this problem

Is this giving a problem when you run php artisan serve?

zey34354 2022-04-03 14:40:22
cletuskingdom 2022-04-03 14:34:27
Is this giving a problem when you run php artisan serve?

no

zey34354 2022-04-03 14:40:34
this in controllerPage
zey34354 2022-04-03 14:41:28
Home controller
2022-04-03 14:56:52
zey34354 2022-04-03 14:19:44
what is the problem in this exactly ?

You missed ; after $number

cletuskingdom 2022-04-03 15:19:59
Did you get this?
Import the namespace for Route, and the error will go off
cletuskingdom 2022-04-03 15:20:57
Screenshot please
eyyubzademireli 2022-04-03 15:21:04
remove )in 50
cletuskingdom 2022-04-03 15:26:02
I’ll prefer a screenshot please, which might lead to other screenshot.

But secondly, have you searched on Google?

cletuskingdom 2022-04-03 15:39:35
Okay, since it’s not disturbing your program; continue like that and when I’m close to my PC; I’ll alert you.
Rao Aadil 2022-04-03 15:41:20
laravel_discuss-113862.jpg
I have re-installed xampp since then I am keep getting this error but my application runs fine. this underline dont go
Rao Aadil 2022-04-03 15:41:31
can anyone help
cletuskingdom 2022-04-03 15:44:10
This should be coming from one of your VsCode plugins, I guess one that checks for error; I’m not certain to remember the name now.
Adam_webdev 2022-04-03 16:42:59
laravel_discuss-113867.jpg
Add , before [
zey34354 2022-04-03 16:44:22
2022-04-03 14:56:52
You missed ; after $number

there is still a mistake like =>

zey34354 2022-04-03 16:45:15
Adam_webdev 2022-04-03 16:42:59
Add , before [

one second

zey34354 2022-04-03 16:46:16
Adam_webdev 2022-04-03 16:42:59
Add , before [

it didn’t work

zey34354 2022-04-03 16:48:41
laravel_discuss-113871.jpg

Adam_webdev 2022-04-03 17:05:06
laravel_discuss-113873.jpg
return view(‘home.test2’,[“id” => $id, “number” => $number]);
rakeden 2022-04-03 17:07:25
The above is wrong in so many ways
zey34354 2022-04-03 17:29:48
laravel_discuss-113876.jpg
what is the problem here too
zey34354 2022-04-03 17:42:47
Adam_webdev 2022-04-03 17:05:06
return view(‘home.test2’,[“id” => $id, “number” => $number]);

thank you so much for that it worked without return because it had a mistake in it

zey34354 2022-04-03 17:43:11
does anyone have a tutorial for laravel
Jack0150 2022-04-03 17:46:09
Anyone worked on websocket in laravel
a 2022-04-03 17:47:15
Anyone can design task management dashboard in php?
cayetanohosma 2022-04-03 19:01:40
Hi guys! I’m stuck wit a really silly issue. I’m trying to define and use a Facade in Laravel 8, and I define the class with function itself:
<?php

namespace AppFacadesv1;

use IlluminateHttpJsonResponse;
use IlluminateHttpRequest;

class EgateUtils
{
public function UnitsToValue(string $input): int
{
$parts = explode([‘KB’, ‘MB’, ‘GB’, ‘TB’, ‘PB’], $input);

}
}

Define the facade class:
<?php

namespace AppFacadesv1;

use IlluminateSupportFacadesFacade;

class EgateUtilsFacade extends Facade
{
protected static function getFacadeAccessor(): string
{
return ‘egateutils’;
}
}
Register at AppServiceProvider.php

/**
* Register services.
*
* @return void
*/
public function register()
{
$this->app->bind(‘utils’, function () {
return new EgateUtils();
});
}

and finally add to app.php in alias array

‘EgateUtils’ => AppFacadesv1EgateUtils::class,

cayetanohosma 2022-04-03 19:05:01
The problem is that when I try to use I get the error: Non-static method App\Facades\v1\EgateUtils::UnitsToValue() cannot be called statically
cayetanohosma 2022-04-03 19:05:51
Any clue, I spent from this morning trying to figureout where is the issue and I can’t find it
cayetanohosma 2022-04-03 19:06:05
I appreciate any help about the fix
Ajmal243 2022-04-03 19:32:35
laravel_discuss-113889.jpg
how to solve this?
Ahmadite999 2022-04-03 19:33:55
Ajmal243 2022-04-03 19:32:35
how to solve this?

Add in Model : fillable

masmos08 2022-04-03 19:35:22
Ajmal243 2022-04-03 19:32:35
how to solve this?

It looks like you have field with name *name* in the database which does not allow bulls

masmos08 2022-04-03 19:35:34
Null
cayetanohosma 2022-04-03 19:42:22
As I see, you have three options,
1) as @Ahmadite999 said
2) set default value for that field
3) define a value for that field on your query
|