You updated to the latest laravel, which means your PHP too was updated to version 8?

|
Laradev 2022-09-11 11:17:18
UVTech_2022 2022-09-11 10:17:06
Can we install breeze template with css bootstrap

I think yes, provided you can play around with the breeze logic

Laradev 2022-09-11 11:18:27
Anybody who thinks vite addition to Laravel is a game changer, been using it lately and mehn i like that shitπŸ”₯πŸ”₯πŸ”₯
Beta_Tech 2022-09-11 11:40:38
Laradev 2022-09-11 11:18:27
Anybody who thinks vite addition to Laravel is a game changer, been using it lately and mehn i like that shitπŸ”₯πŸ”₯πŸ”₯

I don’t like it, I prefer pure ui, HTML-CSS-JS

Laradev 2022-09-11 11:41:26
Beta_Tech 2022-09-11 11:40:38
I don’t like it, I prefer pure ui, HTML-CSS-JS

Why don’t you like it

Beta_Tech 2022-09-11 11:42:01
Forcing a particular tech on people
Laradev 2022-09-11 11:42:04
Vite bundles any changes to blade templates automatically
Beta_Tech 2022-09-11 11:42:26
Not everyone needs extra overhead,
Laradev 2022-09-11 11:42:38
Beta_Tech 2022-09-11 11:42:01
Forcing a particular tech on people

But other stacks like react are also using vite

Laradev 2022-09-11 11:43:04
Beta_Tech 2022-09-11 11:42:26
Not everyone needs extra overhead,

I get your point, to me it’s just awesome,

Beta_Tech 2022-09-11 11:43:36
Yes, I understand that people like it, no problem
Laradev 2022-09-11 11:45:16
You just have to run npn run dev and php artisan serve and enjoy the background bundling of vite, it’s awesome
didaputraad 2022-09-11 12:14:56
Funny
GunMerchant 2022-09-11 13:03:42
Ronnie 2022-09-11 03:39:21
Guys recently I downgraded my PHP version to PHP7.1,
Prior to this my composer is a version 3, and technically this doesn’t support my current specifications for PHP7.1
I have tried some of the options.
(1/2)

Are you coming back from the future or I am living in the past πŸ€“? I thought latest composer version is 2.4?

JeevaniSM 2022-09-11 13:21:56
#help
Hi,
I need to call an external API
so I used below code
—————————————————
$apiResponse = Http::withHeaders([
‘Content-Type’ => ‘application/json’,
‘X-rcee-api’ => ‘1’,
])->get(URL);

return $dataList = json_decode($apiResponse, TRUE);
—————————————————

Now, I need to retry this API call in 100ms, 3 times
so I have this below code
———-
$response = Http::retry(3, 100)->get(URL);
————–

But this time, I dont have the options to send the headers.

How can use multiple HTTP client request methods in a single call ?

Is the below code valid ??

$apiResponse = Http::withHeaders([
‘Content-Type’ => ‘application/json’,
‘X-rcee-api’ => ‘1’,
])::retry(3, 100)->get(URL)->get(URL);

thanks for any help

JeevaniSM 2022-09-11 13:23:00
pls show the code you are inserting into DB
AkshayKrBairwa 2022-09-11 13:56:50
Can somebody help in creating a common configuration file for php project. the file runs on both localhost and hosting server. I uploaded on server but some paths or functions doesn’t working properly…
Ronnie 2022-09-11 15:05:00
GunMerchant 2022-09-11 13:03:42
Are you coming back from the future or I am living in the past πŸ€“? I thought latest composer version is 2.4?

Thanks for all the positive criticism..πŸ˜‚πŸ˜‚
I have finally gotten the solution

Ronnie 2022-09-11 15:12:00
So this is what I learned
1. initially I had downgraded PHP version to the exact version of the cloned project. Let’s say PHP 7.1
2. This PHP version 7.1 ain’t compatible with the latest version of composer 2.4
So it all became an endly infinite loop of errors.
Solutions:
1.
I just upgraded my Laravel version to the latest. This gave me a chance to access the composer once again.
2. Firstly I went ahead to downgrade it now..through composer self-update -2.2
3. Degraded the PHP version to 7.1
Then here we are working and contributing to open source..πŸ˜‚πŸŒ„
Khinsokha 2022-09-11 15:47:05
laravel_discuss-137841.jpg

Khinsokha 2022-09-11 15:47:06
laravel_discuss-137842.jpg

. . 2022-09-11 16:17:14
https://youtu.be/okMYgBf7LaE

Laravel 9 and Vuejs 3 project: Website Portfolio-installing and setupYouTube
In this video we are going to learn Laravel and Vuejs by project: Website Portfolio-installing and setup; Good viewing.

SUBSCRIBE BY CLICKING HERE
https://www.youtube.com/channel/UCgME7xUx_PrCdphF2k8bupg?sub_confirmation=1
Professional contact:

Github: https://github.com/share-tutorials-dev

Did you like the video? Let me know by subscribe,like and commentπŸ€”
Congratulations to today’s signings
YouTube: https://www.youtube.com/channel/UCgME7xUx_PrCdphF2k8bupg?sub_confirmation=1
Github: https://github.com/share-tutorials-dev

Beta_Tech 2022-09-11 16:18:11
Ronnie 2022-09-11 15:12:00
So this is what I learned
1. initially I had downgraded PHP version to the exact version of the cloned project. Let’s say PHP 7.1
2. This PHP version 7.1 ain’t compatible with the latest version of composer 2.4
So it all became an endly infinite loop of errors.
Solutions:
1.
I just upgraded my Laravel version to the latest. This gave me a chance to access the composer once again.
2. Firstly I went ahead to downgrade it now..through composer self-update -2.2
3. Degraded the PHP version to 7.1
Then here we are working and contributing to open source..πŸ˜‚πŸŒ„

Solution 1. You updated to the latest laravel, which means your PHP too was updated to version 8 ?

Kvngthrive 2022-09-11 17:21:27
please I tried implementing a guard on my admin routes and am having some issues
Kvngthrive 2022-09-11 17:21:39
https://flareapp.io/share/LPlBXn85

Laravel error tracking – FlareFlare
Argument 2 passed to IlluminateAuthSessionGuard::__construct() must be an instance of IlluminateContractsAuthUserProvider, null given, called in C:zidaanSCyutav2yuta-v2vendorlaravelframeworksrcIlluminateAuthAuthManager.php on line 125 – The error occurred at http://127.0.0.1:8000/admin/dashboard
Kvngthrive 2022-09-11 17:21:52
TypeError
Argument 2 passed to IlluminateAuthSessionGuard::__construct() must be an instance of IlluminateContractsAuthUserProvider, null given,
Kvngthrive 2022-09-11 17:22:05
please can someone tell me what am doing wrong
shubham Patel 2022-09-11 17:27:13
Kvngthrive 2022-09-11 17:22:05
please can someone tell me what am doing wrong

Your guard name is web??

Kvngthrive 2022-09-11 17:28:00
admins
Vishalvhatkar 2022-09-11 17:28:21
Hi any laravel expert here I need some help
Vishalvhatkar 2022-09-11 17:28:39
I will ready to pay for it
shubham Patel 2022-09-11 17:29:10
‘providers’ => [ ‘users’ => [ ‘driver’ => ‘eloquent’, ‘model’ => AppUser::class, ], ‘admin’ => [ ‘driver’ => ‘eloquent’, ‘model’ => AppAdmin::class, ],
Kvngthrive 2022-09-11 17:32:39
shubham Patel 2022-09-11 17:29:10
‘providers’ => [ ‘users’ => [ ‘driver’ => ‘eloquent’, ‘model’ => AppUser::class, ], ‘admin’ => [ ‘driver’ => ‘eloquent’, ‘model’ => AppAdmin::class, ],

“syntax error, unexpected ‘;’, expecting ‘]'”

Kvngthrive 2022-09-11 17:33:54
shubham Patel 2022-09-11 17:29:10
‘providers’ => [ ‘users’ => [ ‘driver’ => ‘eloquent’, ‘model’ => AppUser::class, ], ‘admin’ => [ ‘driver’ => ‘eloquent’, ‘model’ => AppAdmin::class, ],

still bruh

Vishalvhatkar 2022-09-11 17:36:24
Any one laravel expert please connect meb
sagar_dave_1997 2022-09-11 18:02:44
Vishalvhatkar 2022-09-11 17:36:24
Any one laravel expert please connect meb

Share the problem here

|